Задать вопрос
1 мая, 03:43

1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10.

2) Найти произведение двузначных нечетных чисел.

3) С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных и количество положительных среди введенных чисел. Значение N вводится с клавиатуры.

+2
Ответы (1)
  1. 1 мая, 05:40
    0
    1) var x, s:real; i:integer;

    begin

    s:=0;

    For i:=1 to 10 do begin

    readln (x) ;

    if x > 10 then

    s:=s+x;

    end;

    write (s) ;

    readln

    end.

    2) var p:longint; x, i:integer;

    begin

    p:=1;

    for i: = 1 to 10 do begin

    readln (x) ;

    if (x div 100 = 0) and (x mod 2 0) then

    p:=p*x;

    end;

    write (p) ;

    readln

    end.

    3) var i; n; kp; ko; integer; x:real;

    begin

    readln (n) ;

    kp:=0; ko:=0;

    for i: = 1 to n do begin

    readln (x) ;

    if x > 0 then

    kp:=kp+1

    else

    ko:=ko+1;

    end;

    write ('положительных', kp,'отрицательных', ko) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы