Задать вопрос
26 февраля, 17:22

Напишите программу в Pascal ABC, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 5 или 9. Входные данные: 15 91 90 0 Выходные данные: 2

+1
Ответы (1)
  1. 26 февраля, 19:13
    0
    Var a, k:integer;

    begin

    k:=0;

    readln (a) ;

    while a0 do

    begin

    if (abs (a) mod 5=0) or (abs (a) mod 9=0)

    then k:=k+1;

    readln (a) ;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    15

    91

    90

    0

    k = 2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Pascal ABC, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. Программа получает ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы