Задать вопрос
7 мая, 18:00

На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у Кролика он съел по 100 г меда. Написать программу, определяющую, сколько килограммов меда съест Винни Пух на - ом дне рождения.

Формат входных данных

Во входном файле задано единственное число (1 до 40).

Формат выходных данных

Выведите, сколько килограммов меда съест Винни Пух на этот день рождения с точностью до одного знака после десятичной точки.

+3
Ответы (1)
  1. 7 мая, 19:22
    0
    Var

    n, a, b, c, c2, i:integer;

    Begin

    Write ('Введите число ') ;

    Readln (n) ;

    a:=100;

    b:=100;

    for i: = 1 to n do Begin

    c:=a+b; a:=b; b:=c;

    End;

    c2:=c div 1000;

    write (c2,'.') ;

    c:=c div 100 mod 10;

    write (c,' кг съел Винни') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы