Задать вопрос
27 октября, 13:35

1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы.

2. Вводятся 15 чисел. Определить, сколько среди целых чисел.

3. Вывести все четные числа начиная с числа N и до числа M. Числа N и M задает пользователь.

4. Составить программу, печатающую все делители целого числа в порядке возрастания

+2
Ответы (1)
  1. 27 октября, 14:04
    0
    На паскале.

    1)

    var i, n, sum : integer;

    begin

    sum : = 0;

    for i : = 1 to 10 do

    begin

    readln (n) ;

    sum : = sum + n * n;

    end;

    writeln (sum) ;

    end.

    2)

    var i, sum : integer;

    n : real;

    begin

    sum : = 0;

    for i : = 1 to 15 do

    begin

    readln (n) ;

    if n = trunc (n) then sum : = sum + 1;

    end;

    writeln (sum) ;

    end.

    3) var n, m, i : integer;

    begin

    readln (n, m) ;

    for i : = n to m do

    if i mod 2 = 0 then writeln (i) ;

    end.

    4) var n, i : integer;

    begin

    readln (n) ;

    for i : = 1 to n do

    if n mod i = 0 then writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)