Задать вопрос
26 августа, 00:18

Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

+3
Ответы (1)
  1. 26 августа, 02:44
    0
    Program Main; Var a:array[1 ... 1000]of integer; i, n, k:integer; begin write ('Введите количество элементов в массиве: ') ; readln (n) ; writeln ('Введите массив: ') ; for i:=1 to n do read (a[i]) ; writeln; k:=0; for i:=1 to n-1 do if (a[i]=a[i+1]) then k:=k+1; if (k>0) then writeln ('Есть ', k,' пар соседних элементов с одинаковым значением') else writeln ('Нет пар соседних элементов с одинаковым значением') ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив, состоящий из целых чисел. Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы