Задать вопрос
28 июля, 16:04

Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную

+3
Ответы (1)
  1. 28 июля, 17:18
    0
    Function ToBinaryString (x: integer) : string;

    var r, s: string;

    begin

    if x < 0 then begin

    s : = '-';

    x : = - x;

    end;

    while x 0 do begin

    r : = Chr ((x and 1) or 48) + r;

    x : = x shr 1;

    end;

    ToBinaryString : = s + r;

    end;

    var x: integer;

    begin

    readln (x) ;

    writeln (ToBinaryString (x)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы