Задать вопрос
2 апреля, 19:18

Опишите на одном из языков программирования алгоритм поиска трех последовательных эле-ментов, сумма которых максимальна, в числовом массиве из 30 элементов. вывести номер эле-мента в этой последовательности, сумму последовательности.

+3
Ответы (1)
  1. 2 апреля, 20:39
    0
    Program zadbl;

    uses crt;

    var a, b, c, i, s:integer;

    m:array[1 ... 30] of integer;

    begin

    s:=-1;

    for i:=1 to 30 do

    begin

    m[i]:=random (100) ;

    write (m[i]:3) ;

    end;

    for i:=1 to 28 do

    begin

    if m[i]+m[i+1]+m[i+2]>s then

    begin

    a:=m[i];

    b:=m[i+1];

    c:=m[i+2];

    s:=a+b+c;

    end;

    end;

    writeln (' a b c') ;

    write (a:3) ;

    write (b:3) ;

    write (c:3) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Опишите на одном из языков программирования алгоритм поиска трех последовательных эле-ментов, сумма которых максимальна, в числовом массиве ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)
1) Опишите на русском языке или одном из языков программирования алгоритм подсчета суммы произведений последовательных пар элементов в целочисленном массиве из 30 элементов.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Опишите на русском языке или одном из языков программирования алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов.
Ответы (2)
Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).
Ответы (1)