Задать вопрос
1 ноября, 05:45

Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

+2
Ответы (1)
  1. 1 ноября, 08:06
    0
    var

    a:array [1 ... 30] of integer;

    i, k, s:integer;

    begin

    randomize;

    for i:=1 to 30 do begin

    a[i]:=random (9) + 1;

    write (a[i],' ') ;

    end;

    s:=a[1]+a[2];

    k:=1;

    for i:=2 to 29 do

    if a[i]+a[i+1]>s then begin

    k:=i;

    s:=a[i]+a[i+1];

    end;

    writeln;

    writeln ('Number: ', k) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы