Задать вопрос
10 сентября, 15:53

Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если полученное число останется наибольшим вывести "YES", в противоположном случае вывести "NO".

+1
Ответы (1)
  1. 10 сентября, 16:16
    0
    Var

    a, b, max, min:integer;

    begin

    Write ('Введите два целых двухзначных числа: ') ; Readln (a, b) ;

    if a>b then begin max:=a; min:=b end

    else begin max:=b; min:=a end;

    if (10 * (max mod 10) + (max div 10)) >min then Writeln ('YES')

    else Writeln ('NO')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы