Задать вопрос
22 марта, 00:21

Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal)

1. С клавиатуры вводятся три целых числа. Определите количество положительных чисел в этом наборе.

2. С клавиатуры вводится целое число n. Вычислите сумму S=1+2+3 + ... + n.

3. С клавиатуры вводится целое число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса.

4. Вводится расстояние L в сантиметрах. Выясните, сколько в нём полных метров. Выведите это количество.

+2
Ответы (2)
  1. 22 марта, 00:27
    0
    1) var a1, a2, a3, s: integer;

    begin

    write ('Введите первое число: ') ;

    readln (a1) ;

    write ('Введите второе число: ') ;

    readln (a2) ;

    write ('Введите третье число: ') ;

    readln (a3) ;

    if a1>0 then s:=s+1;

    if a2>0 then s:=s+1;

    if a3>0 then s:=s+1;

    writeln (s) ;

    end.

    2) var n, s, i: integer;

    begin

    write ('Введите число n: ') ;

    readln (n) ;

    for i:=1 to n do

    s:=s+i;

    writeln (s) ;

    end.

    3) var n, s, i, k: integer;

    begin

    write ('Введите число n: ') ; readln (n) ;

    for i:=1 to n do begin

    writeln ('Введите рост ', i,' учащегося: ') ;

    readln (k) ;

    s:=s+k;

    end;

    writeln (s/i) ;

    end.

    4) var l, m: integer;

    begin

    write ('Введите расстояние в сантиметрах: ') ;

    readln (l) ;

    m : = l div 100;

    write ('Количество метров в ', l, ' сантиметрах = ', m) ;

    end.
  2. 22 марта, 00:56
    0
    Program task1;

    var a, i, kol : integer;

    begin

    for i: = 1 to 3 do begin readln (a) ; if a > 0 then inc (kol) ; end; writeln (kol) ;

    end.

    program task2;

    var n, result : integer;

    function summa (x : integer) : integer; var i, sum : integer; begin for i: = 1 to x do sum: = sum + i; summa: = sum; end;

    begin

    readln (n) ; result: = summa (n) ; writeln (result) ;

    end.

    program task3;

    var i, n, growth, sum, kol : integer; SrGrowth : real;

    begin

    readln (n) ; sum: = 0; kol: = 0; for i: = 1 to n do begin readln (growth) ; sum: = sum + growth; inc (kol) ; end; SrGrowth: = sum/kol; writeln (SrGrowth) ;

    end.

    program task4;

    var l : integer;

    begin

    readln (l) ; l: = l div 100; writeln (l) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи: 1) С клавиатуры вводятся 3 целых числа. Определите количество положительных чисел в этом наборе. 2) С клавиатуры вводится натуральное число n. Вычислите сумму S=1+2 + ... + n.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)