Задать вопрос
13 апреля, 07:24

Помогите решить задачи:

1) С клавиатуры вводятся 3 целых числа. Определите количество положительных чисел в этом наборе.

2) С клавиатуры вводится натуральное число n. Вычислите сумму S=1+2 + ... + n.

3) Заполните элементы массива последовательностью чисел: 2,5,10,17,26, ...

+1
Ответы (1)
  1. 13 апреля, 10:33
    0
    1) program fagasg;

    var a, b, c, d: integer;

    begin

    Writeln ('Введите первое число') ;

    readln (a) ;

    Writeln ('Введите второе число') ;

    readln (b) ;

    Writeln ('Введите третье число') ;

    readln (c) ;

    d:=0;

    If a>0 then d:=d+1;

    If b>0 then d:=d+1;

    If c>0 then d:=d+1;

    Writeln ('Количество положительных чисел:', d) ;

    end.

    2) program gsggdfd;

    var n, s, i: integer;

    begin

    writeln ('Введите n') ;

    readln (n) ;

    s:=0;

    For i:=1 to n do

    S:=s+i;

    Writeln ('Сумма последовательности равна:', s) ;

    end.

    3) Program afsdgf;

    var A: Array[1 ... 100] of integer;

    i, h, s, l: integer;

    begin

    Writeln ('ведите размер массива') ;

    readln (h) ;

    s:=1;

    l:=1;

    For i:=1 to h do

    begin

    A[i]:=s+l;

    s:=s+2;

    writeln (A[i]) ;

    l:=A[i];

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачи: 1) С клавиатуры вводятся 3 целых числа. Определите количество положительных чисел в этом наборе. 2) С клавиатуры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы