Задать вопрос
17 июля, 04:00

Составить программу, печатающую все простые числа, не превосходящие данного числа.

паскаль абс

+1
Ответы (1)
  1. 17 июля, 06:32
    0
    Program Prostoe;

    Uses

    Crt;

    Var

    i, {возможный делитель}

    Number : integer; {исследуемое число}

    Begin

    ClrScr;

    writeln (‘Какое число должно быть проверено? ‘) ;

    read (Number) ;

    i : = 1;

    repeat

    i : = i+1;

    until Number mod i = 0;

    if Number=i

    then

    writeln (Number,’ является простым‘)

    else

    writeln (Number,’ делится на ‘, i) ;

    readln;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, печатающую все простые числа, не превосходящие данного числа. паскаль абс ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы