Задать вопрос
22 сентября, 09:27

Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3

+2
Ответы (2)
  1. 22 сентября, 11:16
    0
    Var

    n, d:integer;

    f:Text;

    begin

    Assign (f,'input. txt') ; Reset (f) ;

    Read (f, n) ;

    Assign (f,'output. txt') ; Rewrite (f) ;

    d:=n mod 10;

    while n>=10 do n:=n div 10;

    if n>d then Writeln (f,'>')

    else

    if n=d then Writeln (f,'=') else Writeln (f,'<') ;

    Close (f)

    end.

    TXT
  2. 22 сентября, 11:35
    0
    Var n, i: integer;

    begin

    i : = 3;

    while i < = n do

    begin

    write (i, ' ') ;

    i : = i + 10;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число N. составьте программу, которая выводит все числа от 1 по N, у которых последняя цифра кратная 3 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы