Умоляю, помогите ...
Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм
печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при
вводе которых алгоритм печатает сначала 7, а потом 29.
mod - озгачает остаток от деления нацело, например, 10 mod 3 равно 1 (mod (10,3) = 1), div - деление нацело, например, (10 div 3 = 3 (div (10,3) = 3)
Паскаль
var x, a, b, c: integer;
begin
readln (x) ;
a : = 9; b : = 0;
while x>0 do
begin
c : = x mod 10;
b : = b+c;
if c < = a then a : = c;
x : = x div 10;
end;
writeln (a) ; write (b) ;
end.
Угадайте правило, по которому составлена последовательность, продолжите её:
а) 2,2,4,8,32,256,8192 ...
б) п, в, с, ч, п, с ...
в) 1,11,21,1211,111221,312211,13112221 ...
г) 1 - 0, 8 - 2, 16 - 1, 1990 - 3, 1989 - 4, 100 - 2, 7 - 0, 23 - 0