Задать вопрос
19 апреля, 22:47

Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно переведите в радианы t = f · 3,14 : 180) по формуле S = a 2 sin t

+5
Ответы (1)
  1. 20 апреля, 00:19
    0
    Var

    a, f, t, S: real;

    begin

    Write ('Введите длину стороны ромба: ') ; Readln (a) ;

    Write ('Введите величину острого угла ромба в градусах: ') ; Readln (f) ;

    t : = f * pi / 180;

    S : = sqr (a) * sin (t) ;

    Writeln ('Площадь ромба равна ', S, ' кв. ед.')

    end.

    Тестовое решение:

    Введите длину стороны ромба: 14.3

    Введите величину острого угла ромба в градусах: 58.7

    Площадь ромба равна 174.728286173858 кв. ед.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для нахождения площади ромба по стороне а и острому углу f (угол предварительно переведите в радианы t = f · 3,14 : ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы