Задать вопрос
22 января, 06:47

Введите с клавиатуры целое число в диапазоне 1-999.

а) Определите количество знаков в числе;

б) Определите четность числа;

в) Выведите описание числа, например,"нечетное однозначное число","четное двухзначное число" и тд.

Пример ввода: 347

Пример вывода: Нечетное трехзначное число

+1
Ответы (1)
  1. 22 января, 10:07
    0
    Type num=1 ... 999;

    Var x:num; k, y:integer;

    Begin

    write ('x=') ;

    readln (x) ;

    y:=x;

    k:=0;

    while y0 do

    begin

    y:=y div 10;

    k:=k+1;

    end;

    if (x mod 2) = 0 then

    write ('Четное ')

    else

    write ('Нечетное ') ;

    if k=1 then write ('однозначное ')

    else

    if k=2 then write ('двухзначное ')

    else

    write ('трехзначное ') ;

    writeln ('число') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Введите с клавиатуры целое число в диапазоне 1-999. а) Определите количество знаков в числе; б) Определите четность числа; в) Выведите ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы