Задать вопрос
22 ноября, 21:04

Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25

Программа должна:

1) выводить на экран сначала все элементы массива, стоящие на четных местах, а зате - все элементы массива, стоящие на нечетных местах;

2) вывести на экран сумму всех элементов массива, значения которых кратны 3 или 5.

3) найти минимальное и максимальное значение элементов массива.

+1
Ответы (1)
  1. 22 ноября, 23:44
    0
    Var

    a:array[1 ... 20] of integer;

    i, n, min, max, s:integer;

    begin

    randomize;

    s:=0;

    writeln ('Введи кол-во элементов в массиве') ;

    readln (n) ;

    for i:=1 to n do

    a[i]:=random (35) - 10;

    for i:=1 to n do

    if i mod 2 = 0 then writeln ('a[', i,']=', a[i]) ;

    for i:=1 to n do

    if i mod 2 >0 then writeln ('a[', i,']=', a[i]) ;

    for i:=1 to n do if (a[i] mod 3 = 0) or (a[i] mod 5 = 0) then s:=s+a[i];

    writeln ('Сумма членов кратных 3 или 5 = ', s) ;

    min:=a[1];

    max:=a[1];

    for i:=2 to n do begin

    if a[i]
    if a[i]>max then max:=a[i];

    end;

    writeln ('Максимум=', max) ;

    writeln ('Минимум=', min) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы