Задать вопрос
21 мая, 22:22

Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую найти и вывести элементы массива, которые не кратны 9 и находятся в диапазоне[30,70]. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

+3
Ответы (1)
  1. 22 мая, 01:11
    0
    Const

    auto = true;

    n = 70;

    var

    a: array[1 ... n] of integer;

    i: integer;

    begin

    for i : = 1 to n do

    begin

    if auto then

    a[i] : = random (100)

    else readln (a[i]) ;

    if (a[i] = 30) and (a[i] mod 9 > 0) then

    writeln (a[i]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный массив из 70 элементов. Элементы массива могут принимать целые значения от 0 до 100. Составить программу, позволяющую ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы