Задать вопрос
29 марта, 17:27

Для некоторого предприятия каждый второй год является "удачным" каждый в третий "прибыльным" каждый пятый "замечательным". Текущий год является "удачным", "прибыльным" и "замечательным". Написать программу, определяющую какие годы в следующем десятилетии будут иметь две совпавшие хырактеристики и через сколько лет совпадут все три характеристики.

+3
Ответы (1)
  1. 29 марта, 19:26
    0
    Year = 2013;

    while (true) do

    begin

    inc (year) ;

    fl : = 3;

    if (year mod 2! = 0) then del (fl) ;

    if (year mod 3! = 0) then dec (fl) ;

    if (year mod 5! = 0) then dec (fl) ;

    if (fl = 2) then writeln ('Две совпали') ;

    if (fl = 3) then begin writeln ('Все три совпали') ; break; end;

    end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Для некоторого предприятия каждый второй год является "удачным" каждый в третий "прибыльным" каждый пятый "замечательным". Текущий год ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы