Задать вопрос
18 декабря, 00:50

Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в данном числе.

0

+3
Ответы (1)
  1. 18 декабря, 04:16
    0
    Vari, a, k, m:integer;

    begin

    Repeat

    writeln (' ВВедите число') ;

    readln (a) ; k:=0;

    while a>0 do

    begin

    m:=a mod 10;

    k:=k+1;

    a:=a div 10;

    end;

    Until k<=5;

    writeln (k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая запрашивает у пользователя число, но не больше пятизначного, и выдаёт на экран сообщение о том, сколько цифр в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы