Задать вопрос
18 декабря, 00:40

Арбуз диаметром Д1 см стоит на рынке С1 руб за кг, а арбуз диаметром Д2 см стоит С2 руб за кг. Толщина корки арбуза Т мм. Составить программу, сообщающую, какой арбуз выгоднее купить. Плотность мякоти и корки считать равными.

+3
Ответы (2)
  1. 18 декабря, 00:46
    0
    Var

    d1, d2, t, c1, c2, s1, s2: real;

    begin

    write ('Диаметр 1-го арбуза (см) : ') ;

    readln (d1) ;

    write ('Цена за кг 1-го арбуза: ') ;

    readln (c1) ;

    write ('Диаметр 2-го арбуза (см) : ') ;

    readln (d2) ;

    write ('Цена за кг 2-го арбуза: ') ;

    readln (c2) ;

    write ('Толщина корки (мм) : ') ;

    readln (t) ;

    t:=t/10;

    s1:=c1*power (d1/2,3) / (power ((d1/2-t),3)) ; / / стоимость ед. мякоти 1

    s2:=c2*power (d2/2,3) / (power ((d2/2-t),3)) ; / / стоимость ед. мякоти 2

    if s1
    else writeln ('Покупаем второй') ;

    end.
  2. 18 декабря, 01:17
    0
    (Д1 - (С1+Т1)) - (Д2 - (С2 + Т2)). Если > 0, то выгоднее купить первый арбуз

    Если < 0, то выгоднее купить второй арбуз
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Арбуз диаметром Д1 см стоит на рынке С1 руб за кг, а арбуз диаметром Д2 см стоит С2 руб за кг. Толщина корки арбуза Т мм. Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы