Задать вопрос
3 февраля, 16:56

вычислить сумму положительных и произведение отрицательных элементов массива

написать программу в паскале

+3
Ответы (1)
  1. 3 февраля, 18:44
    0
    var a: array [1 ... 10] of integer;

    s, s1, i: integer;

    begin

    s:=0;

    s1:=1;

    for i:=1 to 10 do

    begin

    readln (a[i]) ;

    if a[i]>0 then s:=s+a[i];

    if a[i]<0 then s1:=s1*a[i];

    end;

    writeln ('Сумма: ', s,', произведение: ', s1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «вычислить сумму положительных и произведение отрицательных элементов массива написать программу в паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы