Задать вопрос
21 марта, 23:03

Написать программу для паскаля. Дан массив x размера n (n=10) целых

чисел, содержащий как положительные, так и отрицательные элементы. Упорядочить

массив следующим образом: сначала идут отрицательные числа, упорядоченные по

невозрастанию, потом положительные, упорядоченные по неубыванию.

+4
Ответы (1)
  1. 22 марта, 02:13
    0
    Program gt;

    var A, B, C:array[1 ... 1000]of longint;

    p, l, n, i, j, k, w:longint;

    begin

    n:=10;

    for i:=1 to n do

    read (A[i]) ;

    k:=0; w:=0;

    for i:=1 to n do

    begin

    if (A[i]<0) then begin

    k:=k+1; b[k]:=a[i];

    end;

    if (A[i]>0) then begin

    w:=w+1;

    c[w]:=a[i];

    end;

    end;

    for i:=1 to k-1 do

    for j:=1 to k-i do

    begin

    p:=b[j]; l:=b[j+1];

    if b[j]
    b[j]:=l; b[j+1]:=p;

    end;

    end;

    for i:=1 to k do

    write (b[i],' ') ;

    for i:=1 to w do

    write (c[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для паскаля. Дан массив x размера n (n=10) целых чисел, содержащий как положительные, так и отрицательные элементы. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы