Задать вопрос
6 июня, 11:03

1. Составьте программу, которая

вычисляет среднюю плотность раствора (в кг/м3) по результатам измерения

плотности 7 проб (задаются в массиве констант: 1205, 1350, 1170, 1320, 1220,

1310, 1180).

+2
Ответы (2)
  1. 6 июня, 11:49
    0
    Если решать с вашими константами:

    program test;

    uses crt;

    var a:array [1 ... 10] of integer;

    i: integer;

    rez:real;

    begin

    rez:=0;

    a[1]=1205; a[2]=1350; a[3]=1170; a[4]=1320; a[5]=1220; a[6]=1310; a[7]=1180;

    for i:=1 to 7 do

    rez:=rez+a[i];

    rez:=rez/7;

    write ('rez = ', rez) ;

    end.

    Но, я предлагаю, чтобы пользователь сам вводил 7 значений, это так:

    program test;

    uses crt;

    var a:array [1 ... 10] of integer;

    i: integer;

    rez:real;

    begin

    rez:=0;

    for i:=1 to 7 do

    read (a[i]) ;

    for i:=1 to 7 do

    rez:=rez+a[i];

    rez:=rez/7;

    write ('rez = ', rez) ;

    end.
  2. 6 июня, 12:46
    0
    Program nikitos1515;

    const mas:array[1 ... 7] of integer = (1205, 1350, 1170, 1320, 1220, 1310, 1180) ;

    var i:integer;

    sredn:real;

    begin

    for i:=1 to 7 do

    sredn:=sredn+mas[i];

    sredn:=sredn/7;

    writeln ('Средняя плотность раствора = ', sredn) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Составьте программу, которая вычисляет среднюю плотность раствора (в кг/м3) по результатам измерения плотности 7 проб (задаются в ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы