Задать вопрос
4 апреля, 00:05

Алгоритм вычисления функции Fn, где n-натуральное число, задан следующими соотношениями:

F1=1; F2=1;

Fn=Fn-2+Fn-1 при n<2

Чему равно F5?

+4
Ответы (1)
  1. 4 апреля, 02:46
    0
    Ошибка в условии!

    Fn=Fn-2+Fn-1 при n>2!

    Программа для вычисления Fn:

    var f1, f2, fn, i:integer;

    begin

    f1:=1; f2:=1;

    for i:=3 to 5 do

    begin

    fn:=f1+f2; f1:=f2; f2:=fn;

    end;

    writeln ('fn=', fn) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Алгоритм вычисления функции Fn, где n-натуральное число, задан следующими соотношениями: F1=1; F2=1; Fn=Fn-2+Fn-1 при n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы