Задать вопрос
29 января, 09:54

В киоске продаётся газета стоимостью 250 руб и журнал стоимостью 900 руб. Составить программу которая спрашивает р желании покупателя (купить журнал или газету), принимает деньги и выдаёт на экран сдачу

+3
Ответы (1)
  1. 29 января, 12:47
    0
    Var

    a, b, r, e:integer;

    begin

    a:=250;

    b:=900;

    writeln ('Что вы желаете купить:') ;

    writeln ('1. Газету') ;

    writeln ('2. Журнал') ;

    writeln ('3. Газету и журнал') ;

    readln (r) ;

    if r=1 then e:=a

    else

    if r=2 then e:=b

    else

    e:=a+b;

    writeln ('Стоимость ', e,' р') ;

    writeln ('Введите деньги') ;

    readln (r) ;

    if r>e then

    writeln ('Ваша сдача ', r-e,'р')

    else

    writeln ('Денег не хватает') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В киоске продаётся газета стоимостью 250 руб и журнал стоимостью 900 руб. Составить программу которая спрашивает р желании покупателя ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы