Задать вопрос
28 мая, 06:52

Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. Шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. Число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22

+2
Ответы (1)
  1. 28 мая, 08:45
    0
    Var n:longint;

    c1, c2:byte;

    s:boolean;

    begin

    s:=false

    readln (n) ;

    c1: = (n mod 10) + ((n div 10) mod 10) + ((n div 100) mod 10) ;

    c2: = ((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10) ;

    if c1=c2 then s:=true;

    if s and ((c2=11) or (c2=22)) then writeln ('supershastlivoe') else

    if s then writeln ('shaslivoe') else writeln ('prostoe') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы