Задать вопрос
18 марта, 21:25

Даны натуральное число n и последовательность целых чисел а1, а2, ..., аn ... Определить количество тех членов последовательности, которые нечетны. Найти сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

+4
Ответы (1)
  1. 18 марта, 23:16
    0
    var a:array[1 ... 1000] of longint;

    kol, s, i, n : longint;

    begin

    readln (n) ;

    for i:=1 to n do read (a[i]) ;

    s : = 0;

    kol : = 0;

    for i:=1 to n do

    begin

    if (a[i] mod 11 = 0) then s : = s + a[i]; / / summa elementov

    if (a[i] mod 2 = 1) then kol : = kol + a[i]; / / kolichestvo nechetnyx

    end;

    writeln (kol, ' ', s) ;

    end;

    после / / нужно удалить ... сорри, что нет блок схемы
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны натуральное число n и последовательность целых чисел а1, а2, ..., аn ... Определить количество тех членов последовательности, которые ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы