Задать вопрос
1 ноября, 03:32

Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную матрицу напечатать.

+5
Ответы (1)
  1. 1 ноября, 06:10
    0
    Var

    i, j, k, p:integer;

    a:array[1 ... 8,1 ... 8]of integer;

    begin

    writeln ('Исходный массив:') ;

    for i:=1 to 8 do

    begin

    for j:=1 to 8 do

    begin

    a[i, j]:=random (20) ;

    write (a[i, j]:3)

    end;

    writeln

    end;

    for i: = 1 to 8 do

    for j: = 1 to 8 do

    for k: = 1 to 8 do

    begin

    if i mod 2=0 then

    begin

    if (a[i, j]
    begin

    p:=a[i, j];

    a[i, j] : = a[i, k];

    a[i, k] : = p

    end

    end

    else

    if a[i, j] > a[i, k] then

    begin

    p:=a[i, j];

    a[i, j] : = a[i, k];

    a[i, k] : = p

    end

    end;

    writeln ('Преобразованный массив:') ;

    for i:=1 to 8 do

    begin

    for j:=1 to 8 do

    write (a[i, j]:3) ;

    writeln

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая упорядочивает элементы четных строк по возрастанию, а нечетных по убыванию. Матрица размером 8 х8. Полученную ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы