Задать вопрос
18 июля, 18:36

Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4) 2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, вычитания и умножения; 2) каждое выражение может содержать только одну арифметическую операцию

+3
Ответы (1)
  1. 18 июля, 20:13
    0
    var y, x:real;

    begin

    readln (x) ;

    y:=2 * (1-x*x+2.5*x*x*x+x*x*x*x) ;

    writeln (x) ;

    end.

    var x, y, z:real;

    begin

    readln (x) ;

    y:=-x*x;

    z:=y*x;

    z:=2.5*z;

    y:=y+z;

    z:=z*x;

    y:=y+z;

    y:=y+1;

    y:=y*2;

    writeln (y) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4) 2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы