Задать вопрос
28 июля, 00:10

Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M (включительно), влево на R элементов.

+5
Ответы (1)
  1. 28 июля, 01:10
    0
    Var

    i, k, m, r, p, j:integer;

    a:array[1 ... 10]of integer;

    begin

    writeln ('Массив: ') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('Введите K, M, R: ') ;

    readln (k, m, r) ;

    for i:=1 to r do

    begin

    j:=k;

    p:=a[j];

    while j
    begin

    a[j]:=a[j+1];

    j:=j+1

    end;

    a[j]:=p;

    end;

    writeln ('Измененный массив:') ;

    for i:=1 to 10 do write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы