Задать вопрос
17 декабря, 17:12

Составить программу в паскале которая проверяет наличие введенного слова в строке

+2
Ответы (1)
  1. 17 декабря, 20:51
    0
    Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

    var s, a:string;

    begin

    write ('Введите строку : ') ;

    readln (s) ;

    write ('Введите слово : ') ;

    readln (a) ;

    if (pos (a, s) 0) then writeln ('Слово "', a,'" в строке есть')

    else writeln ('В строке такого слова нет') ;

    end.

    Тест №1

    Введите строку: Привет участникам олимпиады!

    Введите слово: ник

    Слово "ник" в строке есть

    Тест №2

    Введите строку: Всем привет!

    Введите слово: админ

    В строке такого слова нет
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в паскале которая проверяет наличие введенного слова в строке ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы