Задать вопрос
17 марта, 13:50

Вывести все значения элементов заданной числовой последовательности.

Входные данные: Выходные данные:

Во входном потоке в первой строке записано единственное целое число N (0 < N < = 100) - число элементов числовой последовательности;

Во второй строке перечислены вещественные значения элементов числовой последовательности (через пробел). Значения элементов по модулю не превышают 1000.

В выходной поток вывести значения элементов числовой последовательности в столбик с точностью три знака после запятой.

Пример входного файла (input. txt) :

10

43.4 564.54 32.435 76.654 342.6456 76 ...

+3
Ответы (1)
  1. 17 марта, 16:37
    0
    Var

    a:array[1 ... 1000] of extended;

    i, n:longint;

    begin

    readln (n) ;

    for i:=1 to n do read (a[i]) ;

    writeln;

    for i:=1 to n do writeln (a[i]:0:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вывести все значения элементов заданной числовой последовательности. Входные данные: Выходные данные: Во входном потоке в первой строке ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы