Задать вопрос
29 апреля, 07:26

Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе

+1
Ответы (1)
  1. 29 апреля, 07:38
    0
    uses crt;

    type uchenik=record

    fam:string[20];

    im:string[20];

    kls:string[3];

    end;

    var a:array[1 ... 100] of uchenik;

    n, i, j, k:byte;

    begin

    clrscr;

    writeln ('Сколько учеников n=') ;

    readln (n) ;

    writeln ('Введите данные о ', n,' учениках:') ;

    for i:=1 to n do

    begin writeln ('Ученик ', i) ;

    write (' Фамилия: ') ;

    readln (a[i]. fam) ;

    write (' Имя: ') ;

    readln (a[i]. im) ;

    write (' Класс (год+буква, 11 а) : ') ;

    readln (a[i]. kls) ;

    end;

    writeln ('Однофамильцы в одном классе:') ;

    k:=0; for i:=1 to n-1 do for j:=i+1 to n do

    if (a[i]. fam=a[j]. fam) and (a[i]. kls=a[j]. kls) then

    begin

    k:=1;

    writeln (a[i]. kls,' ', a[i]. fam,' ', a[i]. im,' ', a[j]. fam,' ', a[j]. im) ;

    end;

    if k=0 then write ('Однофамильцев в одном классе нет!') ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу осуществляющую поиск однофамильцев, обучающихся в одном классе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы