Задать вопрос
31 января, 06:00

Чему будет равно значение переменной c в результате выполнения фрагмента программы

a:=1257; c:=0;

while a>0 do begin

if a mod 20 then b:=a mod 10; c:=c+b;

a:=a div 10; end;

1) 5;

2) 13;

3) 16;

4) 18.

+1
Ответы (1)
  1. 31 января, 08:57
    0
    Ответ: 18

    Обоснование:

    Var a, b, c : Integer;

    Begin

    a:=1257; c:=0;

    while a>0 do begin

    if a mod 20 then b:=a mod 10; c:=c+b;

    a:=a div 10; end;

    Writeln (c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Чему будет равно значение переменной c в результате выполнения фрагмента программы a:=1257; c:=0; while a>0 do begin if a mod 20 then b:=a ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы