Задать вопрос
5 декабря, 14:34

Помогите решить задачи по паскалю

1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y)

Используя функцию

sign (x) = - 1 если x<0

0 если x=0

1 если x>0

2. Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8

3. Составить программу получения изображения в котором в 1-ой строке будет изображена 1*, во 2-ой строке 2*, в 3-ей строке 3*, в строке с номером m-m*.

+5
Ответы (1)
  1. 5 декабря, 16:28
    0
    1) var

    x:integer;

    begin

    readln (x) ;

    if x>0 then

    writeln (1)

    else if x<0 then

    writeln (-1)

    else

    writeln (0) ;

    end
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите решить задачи по паскалю 1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y) Используя функцию sign (x) = - 1 если x0 2. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы