Задать вопрос
18 марта, 11:11

Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр

+3
Ответы (1)
  1. 18 марта, 14:50
    0
    Var

    A: integer;

    begin

    readLn (A) ;

    if (A mod 2 = 0) then

    begin

    A : = sqr (A) ;

    WriteLn ('Квадрат введённого числа равен: ', A) ;

    end else

    begin

    A : = ((A mod 100) div 10) + (A mod 10) + (A div 100) ;

    writeLn ('Сумма цифр введённого числа равна: ', A) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы