Задать вопрос
28 февраля, 19:40

Написать программу, которая вычисляет наибольший общий делитель двух целых чисел

Паскаль

+2
Ответы (1)
  1. 28 февраля, 22:27
    0
    Var a, b: integer;

    begin

    Writeln ('Введите два числа') ;

    Readln (a, b) ;

    repeat

    if a > b then a : = a Mod b else

    b : = b Mod a;

    until (a = 0) Or (b = 0) ;

    writeln ('НОД = ', a + b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы