Задать вопрос
3 июля, 21:06

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

+3
Ответы (1)
  1. 3 июля, 21:44
    0
    Program gt;

    label 1;

    var n, i, s:integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to 12 do

    begin

    if (i=1) or (I=3) or (i=5) or (i=7) or (i=8) or (i=10) or (i=12) then begin

    s:=s+31;

    if (n<=s) then begin

    writeln (n-s+31,' ', i) ;

    goto 1;

    end;

    end;

    if (i=2) then begin

    s:=s+28;

    if (n<=s) then begin

    writeln (n-s+28,' ', i) ;

    goto 1;

    end;

    end;

    if (i=4) or (i=6) or (i=9) or (i=11) then begin

    s:=s+30;

    if (n<=s) then begin

    writeln (n-s+31,' ', i) ;

    goto 1;

    end;

    end;

    end;

    1:

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы