Задать вопрос
3 сентября, 07:26

Pascal (Паскаль). Очень прошу помощи

Составить программу сортировки массива методом пузырька НО не использовать for

Только через repeat + использовать flag

Всего в программе должно быть 3 переменных: i, flag, b:integer;

Заранее благодарен, тому кто поможет свяжусь и отблагодарю отдельно

+3
Ответы (1)
  1. 3 сентября, 07:34
    0
    Program test;

    const n = 5;

    var i, flag, b:integer;

    m:array [1 ... n] of integer;

    begin

    b:=1;

    for i:=1 to n do

    readln (m[i]) ;

    repeat

    b:=b+1;

    if m[b]
    begin

    flag:=m[b-1];

    m[b-1]:=m[b];

    m[b]:=flag;

    b:=1;

    end;

    until b=n;

    for i:=1 to n do

    writeln (i,') ', m[i]) ;

    end.

    P. S. я использую for только для записи и вывода
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal (Паскаль). Очень прошу помощи Составить программу сортировки массива методом пузырька НО не использовать for Только через repeat + ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы