Задать вопрос
5 апреля, 01:56

Паскаль!

1. Напишите программу, запрашивающую у

пользователя два момента времени (количество часов, минут и секунд) и

сообщающую число секунд, прошедшее между этими двумя моментами.

2. Ввести

два числа. Если сумма этих чисел четная, найти произведение, в противном

случае, найти частное этих чисел.

3. Одноклеточная

амёба каждые 3 часа делится на 2 клетки. Определить, сколько будет амёб через

3,6,9,12, ...24 часа.

4. Дан одномерный массив А (i), i = 7, заданный случайным образом.

Вывести на экран массив, значения которого находятся в диапазоне [0; 10]

+4
Ответы (1)
  1. 5 апреля, 02:05
    0
    1) var a, b, c, a1, b1, c1, s:integer;

    begin

    writeln ('Введите количество часов в первом моменте времени') ;

    readln (a) ;

    writeln ('Введите количество минут в первом моменте времени') ;

    readln (b) ;

    writeln ('Введите количество секунд в первом моменте времени') ;

    readln (c) ;

    writeln ('Введите количество часов во втором моменте времени') ;

    readln (a1) ;

    writeln ('Введите количество минут во втором моменте времени') ;

    readln (b1) ;

    writeln ('Введите количество секунд во втором моменте времени') ;

    readln (c1) ;

    s:=abs (a*3600+b*60+c-a1*3600-b1*60-c1) ;

    writeln (s,' секунд') ;

    end.

    2) var a, b:integer;

    s:real;

    begin

    writeln ('Введите первое число') ;

    readln (a) ;

    writeln ('Введите второе число') ;

    readln (b) ;

    if (a+b) mod 2 = 0 then s:=a*b

    else s: = a/b;

    writeln (s) ;

    end.

    3) var b, s, n:real;

    begin

    writeln ('Введите количество часов') ;

    readln (n) ;

    n:=n/3;

    s:=2*power (2, (n-1)) ;

    writeln (s,' амёб') ;

    end.

    4) var a:array[1 ... 7]of integer;

    i:integer;

    begin

    for i:=1 to 7 do

    begin

    a[i]:=random (11) ;

    writeln ('a[', i,'] = ', a[i]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль! 1. Напишите программу, запрашивающую у пользователя два момента времени (количество часов, минут и секунд) и сообщающую число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы