Задать вопрос
15 декабря, 13:36

Имеется информация об адресах учеников одного класса в виде: фамилия, имя, город, улица, № дома. Написать программу, позволяющую вывести список учеников, проживающих в городе

+2
Ответы (1)
  1. 15 декабря, 14:50
    0
    Type

    Uch=record

    fam:string[20];

    nam:string[20];

    city:string[20];

    street:string[20];

    numb:string[8]

    end;

    var

    f:file of Uch;

    bUch:Uch; { буфер }

    c:string;

    begin

    Assign (f,'Uch. txt') ;

    Reset (f) ;

    Write ('Введите название города: ') ; Readln (c) ;

    while not Eof (f) do begin

    Read (f, bUch) ;

    if c=Trim (bUch. city) then

    With bUch do Writeln (fam,' ', nam,' ', street,' ', numb)

    end;

    Close (f)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Имеется информация об адресах учеников одного класса в виде: фамилия, имя, город, улица, № дома. Написать программу, позволяющую вывести ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы