Задать вопрос
22 декабря, 05:27

С клавиатуры вводят строку, состоящую из латинских букв

и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой

строке, а также выводящую строку после исключения из неё этих цифр. Для паскаль abc.

+5
Ответы (1)
  1. 22 декабря, 05:36
    0
    Var s, al:string; a, i:integer;

    begin

    read (s) ;

    al:='1234567890';

    i:=length (s) ;

    while i>0 do begin

    if poa (s[i], al) 0 then begin a:=a+strtoint (s[i]) ; delete (s, i, 1) ; end;

    i:=i-1;

    end;

    writeln (Сумма: ', a) ;

    writeln ('Строка без цифр: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводят строку, состоящую из латинских букв и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы