Задать вопрос
22 февраля, 12:12

Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее количество банок воды потребуется для подготовки N (N<100) литров раствора?

Пример:

Входные данные = 10

Выходные данные = 3 3 3 1

+1
Ответы (1)
  1. 22 февраля, 14:00
    0
    var

    x, y: byte;

    begin

    readln (x) ;

    repeat

    if (x div 3 > 0) then

    begin

    write (3:2) ;

    x - = 3;

    end

    else

    if (x div 2 > 0) then

    begin

    write (2:2) ;

    x - = 2;

    end

    else

    if (x > 0) then

    begin

    write (1:2) ;

    x - = 1;

    end;

    until (x = 0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Работница теплицы готовит раствор для подкормки растений. В ее распоряжении имеются стеклянные банки 1, 2, и 3 литра. Какое наименьшее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы