Задать вопрос
17 декабря, 11:23

Составьте программу позволяющую определить являются ли числа a, b, c пифагоровыми тройками.

+4
Ответы (1)
  1. 17 декабря, 15:21
    0
    Var

    a, b, c: real;

    begin

    writeln ('Введите числа a, b, c') ;

    readln (a, b, c) ;

    if (sqr (a) = sqr (b) + sqr (c)) or (sqr (b) = sqr (a) + sqr (c)) or (sqr (c) = sqr (a) + sqr (b)) then

    writeln ('Данные числа являются пифагоровым тройками')

    else

    writeln ('Данные числа не являются пифагоровым тройками') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу позволяющую определить являются ли числа a, b, c пифагоровыми тройками. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы