Задать вопрос
3 декабря, 07:30

дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности

+3
Ответы (1)
  1. 3 декабря, 10:31
    0
    На паскале

    program m1;

    var a: aarray [1 ... 10] of integer;

    i, n, k: integer;

    begin

    readln (n) ;

    for i: = 1 to n do readln (a[i]) ;

    k: = 0;

    for i: = 1 to n do begin

    if a[i]0 then k: = k+1;

    end;

    writeln (k) {если 0 нужно учитывать в количестве то ... } writeln (k+1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «дана последовательность целых чисел, заканчивающаяся нулем. написать программу, котороая подсчитывает количество чисел в последовательности ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы