Задать вопрос
27 октября, 00:14

В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого товара и его индекс.

+4
Ответы (1)
  1. 27 октября, 00:56
    0
    Массив данных о стоимости товаров зададим в виде целочисленных констант

    program primer_1;

    const a: array[1 ... 12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58) ;

    i, min, k: integer;

    begin

    min:=a[1];

    for i:=2 to 12 do if a[i]
    begin

    min:=a[i];

    k:=i;

    write ('минимальная стоимость ', min, ' индекс', k)

    end.

    Или скорее всего этот вариант

    program primer_1;

    var a: array[1 ... 12] of integer;

    i, min, k: integer;

    begin

    for i:=1 to 12 do read (a[i]) ; {Ввод стоимостей товаров}

    min:=a[1];

    k:=0;

    for i:=2 to 12 do

    if a[i]
    then

    begin

    min:=a[i];

    k:=i;

    end;

    write ('мин. сто-мость ', min, ' индекс ', k)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого товара и его индекс. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы