Задать вопрос
8 января, 16:43

составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и информация об уровне безработицы в регионе. Определите три наиболее благополучных и три неблагополучных района

+1
Ответы (1)
  1. 8 января, 20:11
    0
    A:array[1 ... 40] of string;

    b:array[1 ... 40] of integer; {буду считать что информация по безработице-число}

    i, n, j, m:integer;

    begin

    for i:=1 to 40 do

    readln (a[i]) ;

    readln (b[i]) ;

    for i:=1 to 40 do

    for j:=1 to 40 do

    if b[i]>b[j] then begin

    n:=a[i]; a[i]:=a[j]; a[j]:=n;

    m:=b[i]; b[i]:=b[j]; b[j]:=m; end;

    writeln ('неблагополучные регионы:') ;

    for i:=1 to 3 do

    writeln (a[i],' ', b[i]) ;

    writeln ('благополучные регионы:') ;

    for i:=40 downto 38 do

    writeln (a[i],' ', b[i]) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу на паскаль: Имеются сведения о 40-и регионах страны: название региона и информация об уровне безработицы в регионе. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы