Задать вопрос
25 мая, 21:21

Написать программу, вычисляющую произведение цифр в сумме трех целых числа A, B И C.

Входной файл

В единственной строке файла содержатся три целых числа A, B И C, разделенных пробелами.

Выходной файл

Выходной файл содержит одно число - искомое произведение цифр.

Задачу решить на языке паскаль.

+2
Ответы (1)
  1. 26 мая, 00:31
    0
    Function ProdDig (n:longint) : longint;

    var

    p:longint;

    begin

    p:=1;

    while n>0 do begin

    p:=p * (n mod 10) ;

    n:=n div 10

    end;

    ProdDig:=p

    end;

    var

    f:Text;

    a, b, c:longint;

    begin

    Assign (f,'abc. txt') ;

    Reset (f) ;

    Readln (f, a, b, c) ;

    Close (f) ;

    Assign (f,'abcout. txt') ;

    Rewrite (f) ;

    Writeln (f, ProdDig (a+b+c)) ;

    Close (f)

    end.

    Вариант без использования функции:

    var

    f:Text;

    a, b, c, p, s:longint;

    begin

    Assign (f,'abc. txt') ;

    Reset (f) ;

    Readln (f, a, b, c) ;

    Close (f) ;

    s:=a+b+c; p:=1;

    while s>0 do begin

    p:=p * (s mod 10) ;

    s:=s div 10

    end;

    Assign (f,'abcout. txt') ;

    Rewrite (f) ;

    Writeln (f, p) ;

    Close (f)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, вычисляющую произведение цифр в сумме трех целых числа A, B И C. Входной файл В единственной строке файла содержатся ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы