Задать вопрос
23 августа, 02:46

Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической прогрессии и сумму первых n членов Sn. Если Sn≤25, то вычислить процентное отношение первого и последнего членов арифметической прогрессии. Написать программу на языке Паскаль

+3
Ответы (1)
  1. 23 августа, 06:02
    0
    Var

    k, i:integer;

    a, b, bk, d, s, p:real;

    begin

    write ('Первый член: ') ;

    readln (a) ;

    write ('Разность прогрессии: ') ;

    readln (d) ;

    write ('Число членов k: ') ;

    readln (k) ;

    bk:=a + (k-1) * d;

    b:=bk-d;

    s: = (a+bk) / 2*k;

    if s<=25 then p:=a/bk*100;

    writeln (k-1,' член: ', b) ;

    writeln (k,' член: ', bk) ;

    writeln ('Сумма: ', s) ;

    if p>0 then writeln ('Первый составляет ', p,'% от последнего')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы